It is currently Thu Apr 24, 2014 7:08 am



Reply to topic  [ 7 posts ] 
 disabling mouse smoothing (working now) 
Author Message
Lt. Colonel
Lt. Colonel
User avatar

Joined: Fri Nov 20, 2009 5:38 pm
Posts: 702
Post disabling mouse smoothing (working now)
CarbonFire;13997695 wrote:OK, Here it is guys....

CARBONFIRE'S Mouse Smoothing and Turret Speed Fix for BFBC2

This fix will change the way your mouse works in-game for both your regular infantry view and when using stationary / vehicle turrets or Choppers.

Currently Battlefield Bad Company 2 has mouse smoothing on by default, with no way of turning the feature off in the game's settings. Mouse Smoothing normalizes your mouse's input, "smoothing out" very fast or very slow movements. The result of this smoothing is often aiming that feels floaty or laggy, which is obviously not desirable in an FPS!

Also BFBC2 turrets tend to turn at a much slower rate compared to normal infantry mouse aiming. This fix will solve that problem and opens the potential for turrets to reach their maximum turning speed without affecting infantry movement. This will also make vehicle turrets turn faster, but they have a hard-coded maximum turning speed, so don't expect to pull a quick 180 with a tank turret anytime soon.

=========
DISCLAIMER: This fix involves changing values within key game files that are relied upon to properly run BFBC2. It is advised that you back up these files prior to editing, and that you don't go changing any values outside the ones shown below. Use this fix at your own risk, you assume all responsibility if you mess up your game.
=========

Ok, with that out of the way, here are the steps to killing mouse smoothing and fixing those slow turrets:

Go to your My Documents > BFBC2 folder. We will be making changes to the Gamesettings.ini file, as well as the files within the <input> folder, so go ahead and make back-up copies of those first.

  1. Make sure BFBC2 is closed
  2. Open GameSettings.ini and make the following changes:

    Sensitivity0=0.000000
    Sensitivity1=0.000000
    Sensitivity2=0.000000
    .
    .
    .
    Scheme0Sensitivity=2.50000 <--- This value will be your normal in-game mouse sensitivity, it seems to have no effect on turrets or vehicles. Feel free to experiment with this value and change as necessary. I found 2.5 to be a good compromise between fast turning speed and precision with a 1000DPI mouse, but YMMV. Values from 0.001 to 500+ are valid.
    .
    .
    InputAcceleration=0

  3. Save and close GameSettings.ini
  4. Navigate to the <input> folder, open infantry.dbx using notepad
  5. Search for the following line:
    <field name="ConceptIdentifier">ConceptPitch</field>
  6. Below this line you'll see several similar-looking blocks of data. Make the following changes:

    Image
  7. Just Below this section you'll find a similar section with the following header:
    <field name="ConceptIdentifier">ConceptYaw</field>

    Repeat Step #6 here, changing the "NormalizeInput" values to false.
  8. Save and close infantry.dbx

    Mouse Smoothing should be effectively disabled at this point. However this change will render turrets and vehicles nearly impossible to use, so make sure you follow the remaining steps...
    .
  9. In the <input> folder, open land.dbx using notepad
  10. Search for the following line:
    <field name="ConceptIdentifier">ConceptPitch</field>
  11. Again, you'll see several similar-looking blocks of data below this section. Make the following changes:

    Image

    Note: 10 here is a suggestion, again feel free to experiment. Values below 5 seemed too sluggish for my taste, while values far greater than 20 did not seem to make turrets any faster at turning, just more "squirrely" (changing directions more quickly, making it harder to stay on target).
    .
  12. Just Below this section you'll find a similar section with the following header:
    <field name="ConceptIdentifier">ConceptRoll</field>

    Repeat Step #11 here, changing the "NormalizeInput" values to false, and changing the ScaleValue to your desired value.
  13. Save and close land.dbx

    Note: The next section applies only to piloting Helicopters (not including the UAV). Gunner seats and the UAV seem to follow the "land" control guidelines for turning speed. Also this fix was only tested for mouse flight. If you fly with a joystick or keyboard-only controls, you'll probably have to play with these settings a bit more to get them to work with your setup. Good Luck!
    .
  14. In the <input> folder, open air.dbx using notepad
  15. Same as before, search for the following line:
    <field name="ConceptIdentifier">ConceptPitch</field>
  16. Find the ScaleValue field for the mouse input and change it to 200
    (NormalizeInput should already be false for air vehicles, but if it isn't, make sure it's set to false).
  17. Search for the following line:
    <field name="ConceptIdentifier">ConceptRoll</field>

    Find the ScaleValue field and change it to 200

    Choppers seem to need much higher values to compensate for setting the "main" mouse sensitivity to zero in step 2. Much lower than 100 and the chopper is hard to move. I tried up to 300, and while it worked, it wasn't a significant change. Again, experiment and find a value that suits you. Like turrets, there is a hard-coded maximum turning speed that the game allows, so don't expect this to transform your chopper into a super stunt machine.
    .
  18. Save and close air.dbx
  19. Start up BFBC2
  20. ENJOY!
  21. (optional)Curse EA as the servers go down again and go play single-player instead


One final note: Vehicles / Turrets will always be affected by some smoothing, as there is no Scheme#Sensitivity or other setting I was able to find in GameSettings.ini that changed vehicle/turret behavior.

Hope this tutorial makes your BC2 experience just a little more awesome.

See you on the Battlefield soldier 8-)

_________________
Don’t stop, PC! Don’t let those ailing console machine devices hold you back.


Last edited by jswizzy on Mon Mar 15, 2010 11:54 am, edited 4 times in total.



Wed Mar 03, 2010 4:28 am
Profile
Master Corporal
Master Corporal

Joined: Sun Feb 10, 2008 6:33 pm
Posts: 52
Post Re: disabling mouse smoothing
Worked like a charm...thanks for the tip.

Edit....not quite like a charm...mounted mg or vehicles the movement in VERY slow.


Wed Mar 03, 2010 12:42 pm
Profile
Lt. Colonel
Lt. Colonel
User avatar

Joined: Fri Nov 20, 2009 5:38 pm
Posts: 702
Post Re: disabling mouse smoothing
yea I noticed this aswell, Maybe someone will be able to figure this out

_________________
Don’t stop, PC! Don’t let those ailing console machine devices hold you back.


Wed Mar 03, 2010 4:12 pm
Profile
Post Re: disabling mouse smoothing
Hi, new here, got to the site googling how to disable the mouse smoothing. I agree that this does seem to make for nearly perfect mouse control "on foot" and renders all vehicle mouse movement dead.

I starting looking closely at the mosue settings in an attempt to get the sluggish feel of the turrets closer to previous BF series games. Lacking the different sensitivity sliders for On Foot/In Vehicle/As Pilot I was going to go with an external fix through my mouse DPI hotswitch and DPI adjustments. Basically I tried to find an in-game sensitivity @2000dpi that was suitable for the turrets and then adjust everything else down from there. What I found was a bit more disturbing.

I ran the Sensitivity slider to maximum in game, no acceleration (none in the OS either) and loaded the single player mission Heavy Metal. I then position my mouse all the way to the left of my mouse pad and when then moved it quickly across the 12" pad. I got about a 90° rotation, however I noticed my crosshairs had managed to go to max elevation. Thinking it was curious I picked up my mouse and moved it back to the left side so it wouldn't track and just the minute movement of picking it up caused the crosshairs to go crazy. Another full slide to the left, faster this time netted me the same 90° traverse and some erratic elevation changes. The small movements vertically as I moved the mouse a long distance horizontally translated to sluggish traverse and rapid elevation. I then tried to traverse the turret slower and lo and behold the turret rotated faster. In fact if I just slow down the movement across the pad I can get 4 full rotations.

Now I am no mathematician, but that sounds like Negative Acceleration. The faster you try to go the slower you rotate, the slower you move your mouse the quicker the rotation. I only noticed this in the tanks, because there is no conceivable way to measure your rotation on foot or in a chopper, and at max sensitivity on foot you just spin in place and puke. I don't know if this is a leftover from the console versions (see Mass Effect 2 for some terrible mouse smoothing left over from the console version) or if the negative acceleration is intentional. One thing is for sure, you bind a KEY to traverse the turret and you can get a full rotation in 5s with no acceleration.

I don't know if anyone on these forums can do anything with this info, but the one tweak here is fantastic for infantry, even if it renders vehicle usage dead. I can only hope that EA/DICE addresses this with more sliders, or some transparency about what the schemes and sensitivities in the .ini's are for. I managed to get every BF game up until this one tweaked exactly how I wanted it control wise and I don't think this one will be an exception. Hopeful communities like this one will work toward making it a better experience considering EA's past stance of non-communication.


Sun Mar 07, 2010 10:45 pm
Master Corporal
Master Corporal

Joined: Mon Nov 24, 2008 1:25 pm
Posts: 84
Post Re: disabling mouse smoothing
So mouse smoothing is what makes my aim feel like it's on a grid?

_________________
C2Q@3.25GHz | GTX460 TOP @ 800 core / 3800 mem
4GB RAM | Gigabyte GA-X48-DQ6
X-Fi Fatal1ty | 1TB WD Caviar Black

And Black Ops runs better on an Xbox.


Wed Mar 10, 2010 6:58 pm
Profile
Lt. Colonel
Lt. Colonel
User avatar

Joined: Fri Nov 20, 2009 5:38 pm
Posts: 702
Post Re: disabling mouse smoothing
Ok someone figured it out so I edited my first post with the correct info http://forums.penny-arcade.com/showpost.php?p=13997695&postcount=1684

I'm using Scheme0Sensitivity=1.00000 @ 800 DPI instead of 2.50000 seems to allow for more precise shots

_________________
Don’t stop, PC! Don’t let those ailing console machine devices hold you back.


Last edited by jswizzy on Fri Mar 19, 2010 6:18 am, edited 1 time in total.



Mon Mar 15, 2010 11:27 am
Profile
Master Corporal
Master Corporal

Joined: Sun Feb 10, 2008 6:33 pm
Posts: 52
Post Re: disabling mouse smoothing (working now)
Almost have it right...only thing missing is the ATV and the jet ski.
Those are controlled in the land.dbx file under the heading of:

<field name="ConceptIdentifier">ConceptCameraYaw</field>

Just change those values the same as the others...only I recommend a value of 2-4 or you're head will spin around way too fast.


Thu Mar 18, 2010 11:18 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.